GoogleApi.ContainerAnalysis.V1beta1.Model.PackageIssue (google_api_container_analysis v0.14.0) View Source

This message wraps a location affected by a vulnerability and its associated fix (if one is available).

Attributes

  • affectedLocation (type: GoogleApi.ContainerAnalysis.V1beta1.Model.VulnerabilityLocation.t, default: nil) - Required. The location of the vulnerability.
  • fixedLocation (type: GoogleApi.ContainerAnalysis.V1beta1.Model.VulnerabilityLocation.t, default: nil) - The location of the available fix for vulnerability.
  • severityName (type: String.t, default: nil) - Deprecated, use Details.effective_severity instead The severity (e.g., distro assigned severity) for this vulnerability.

Link to this section Summary

Functions

Unwrap a decoded JSON object into its complex fields.

Link to this section Types

Specs

t() :: %GoogleApi.ContainerAnalysis.V1beta1.Model.PackageIssue{
  affectedLocation:
    GoogleApi.ContainerAnalysis.V1beta1.Model.VulnerabilityLocation.t() | nil,
  fixedLocation:
    GoogleApi.ContainerAnalysis.V1beta1.Model.VulnerabilityLocation.t() | nil,
  severityName: String.t() | nil
}

Link to this section Functions

Specs

decode(struct(), keyword()) :: struct()

Unwrap a decoded JSON object into its complex fields.