View Source GoogleApi.OSConfig.V1.Model.OSPolicyResourcePackageResourceRPM (google_api_os_config v0.20.0)

An RPM package file. RPM packages only support INSTALLED state.

Attributes

  • pullDeps (type: boolean(), default: nil) - Whether dependencies should also be installed. - install when false: rpm --upgrade --replacepkgs package.rpm - install when true: yum -y install package.rpm or zypper -y install package.rpm
  • source (type: GoogleApi.OSConfig.V1.Model.OSPolicyResourceFile.t, default: nil) - Required. An rpm package.

Link to this section Summary

Functions

Unwrap a decoded JSON object into its complex fields.

Link to this section Types

Specs

t() :: %GoogleApi.OSConfig.V1.Model.OSPolicyResourcePackageResourceRPM{
  pullDeps: boolean() | nil,
  source: GoogleApi.OSConfig.V1.Model.OSPolicyResourceFile.t() | nil
}

Link to this section Functions

Specs

decode(struct(), keyword()) :: struct()

Unwrap a decoded JSON object into its complex fields.