View Source GoogleApi.OSConfig.V1.Model.VulnerabilityReportVulnerabilityItem (google_api_os_config v0.20.0)

OS inventory item that is affected by a vulnerability or fixed as a result of a vulnerability.

Attributes

  • availableInventoryItemId (type: String.t, default: nil) - Corresponds to the AVAILABLE_PACKAGE inventory item on the VM. If the vulnerability report was not updated after the VM inventory update, these values might not display in VM inventory. If there is no available fix, the field is empty. The inventory_item value specifies the latest SoftwarePackage available to the VM that fixes the vulnerability.
  • fixedCpeUri (type: String.t, default: nil) - The recommended CPE URI update that contains a fix for this vulnerability.
  • installedInventoryItemId (type: String.t, default: nil) - Corresponds to the INSTALLED_PACKAGE inventory item on the VM. This field displays the inventory items affected by this vulnerability. If the vulnerability report was not updated after the VM inventory update, these values might not display in VM inventory. For some operating systems, this field might be empty.
  • upstreamFix (type: String.t, default: nil) - The upstream OS patch, packages or KB that fixes the vulnerability.

Link to this section Summary

Functions

Unwrap a decoded JSON object into its complex fields.

Link to this section Types

Specs

t() :: %GoogleApi.OSConfig.V1.Model.VulnerabilityReportVulnerabilityItem{
  availableInventoryItemId: String.t() | nil,
  fixedCpeUri: String.t() | nil,
  installedInventoryItemId: String.t() | nil,
  upstreamFix: String.t() | nil
}

Link to this section Functions

Specs

decode(struct(), keyword()) :: struct()

Unwrap a decoded JSON object into its complex fields.