View Source Change Log

All notable changes to this project will be documented in this file. This project adheres to Semantic Versioning and Keep a CHANGELOG.

0-3-7-2023-01-23

0.3.7 - 2023-01-23

added

Added

Compare v0.3.6...v0.3.7

0-3-6-2022-11-03

0.3.6 - 2022-11-03

This version is just upgraded to RDF.ex 1.0.

Elixir versions < 1.11 are no longer supported

Compare v0.3.5...v0.3.6

0-3-5-2022-04-26

0.3.5 - 2022-04-26

added-1

Added

  • the JSON.LD.Encoder now supports implicit compaction by providing a context as a map, a RDF.PropertyMap or a URL string for a remote context with the new :context option

changed

Changed

Compare v0.3.4...v0.3.5

0-3-4-2021-12-13

0.3.4 - 2021-12-13

Elixir versions < 1.10 are no longer supported

fixed

Fixed

Compare v0.3.3...v0.3.4

0-3-3-2020-10-13

0.3.3 - 2020-10-13

This version mainly upgrades to RDF.ex 0.9.

added-2

Added

  • proper typespecs so that Dialyzer passes without warnings (@rustra)

Compare v0.3.2...v0.3.3

0-3-2-2020-06-19

0.3.2 - 2020-06-19

added-3

Added

Support for remote contexts (@KokaKiwi and @rustra)

Compare v0.3.1...v0.3.2

0-3-1-2020-06-01

0.3.1 - 2020-06-01

This version just upgrades to RDF.ex 0.8. With that Elixir version < 1.8 are no longer supported.

Compare v0.3.0...v0.3.1

0-3-0-2018-09-17

0.3.0 - 2018-09-17

No significant changes. Just some adoptions to work with RDF.ex 0.5. But together with RDF.ex 0.5, Elixir versions < 1.6 are no longer supported.

Compare v0.2.3...v0.3.0

0-2-3-2018-07-11

0.2.3 - 2018-07-11

  • Upgrade to Jason 1.1
  • Pass options to JSON.LD.Encoder.encode/2 and JSON.LD.Encoder.encode!/2 through to Jason; this allows to use the new Jason pretty printing options

Compare v0.2.2...v0.2.3

0-2-2-2018-03-17

0.2.2 - 2018-03-17

added-4

Added

changed-1

Changed

  • Use Jason instead of Poison for JSON encoding and decoding, since it's faster and more standard conform

Compare v0.2.1...v0.2.2

0-2-1-2018-03-10

0.2.1 - 2018-03-10

changed-2

Changed

  • Upgrade to RDF.ex 0.4.0
  • Fixed all warnings (@talklittle)

Compare v0.2.0...v0.2.1

0-2-0-2017-08-24

0.2.0 - 2017-08-24

changed-3

Changed

  • Upgrade to RDF.ex 0.3.0

Compare v0.1.1...v0.2.0

0-1-1-2017-08-06

0.1.1 - 2017-08-06

changed-4

Changed

  • Don't support Elixir versions < 1.5, since URI.merge is broken in earlier versions

Compare v0.1.0...v0.1.1

0-1-0-2017-06-25

0.1.0 - 2017-06-25

Initial release