Module dep_updater

Core module of the system.

Description

Core module of the system. Updates a list of dependencies according to the provided options.

Data Types

deps()

deps() = [atom() | tuple()]

opts()

opts() = #{just_hex := boolean(), update_approx := boolean(), term() => term()}

Function Index

update/2Updates each updateable dependency in Deps.

Function Details

update/2

update(Deps::deps(), Opts::opts()) -> deps()

Updates each updateable dependency in Deps.

It will update all hex packages with fixed or similar (~>) semver requirements and all deps linked to a particular tag in a git repository.

If #{just_hex := true} = Opts, it only checks pacakges from hex.pm.

If #{update_approx := false} = Opts, it only check exact versions.

If #{ignore := [atom,...]} = Opts, the specified deps won't be updated.


Generated by EDoc